Saltar hasta el contenido principal
Pregunta
CoRubrics
Preguntado hace 7 meses

Buenos días, a la hora de procesar los resultados del formulario CoRubrics no me da ninguna media. ¿Hay algo que estoy haciendo mal? Dejo una captura por si me podéis ayudar. Un agradecido saludo.

Inscríbete en la comunidad GEG Spain para realizar preguntas y pedir ayuda a la comunidad.

Prueba lo que te he respondido en el otro hilo:

Cambia la fórmula :

=SI.ERROR(REDONDEAR(SUMAPRODUCTO(filter({G4;J4;M4;P4;S4;V4;Y4;AB4;AE4;AH4};ESNUMERO({G4;J4;M4;P4;S4;V4;Y4;AB4;AE4;AH4}));filter({F2;I2;L2;O2;R2;U2;X2;AA2;AD2;AG2;AJ2};ESNUMERO({G4;J4;M4;P4;S4;V4;Y4;AB4;AE4;AH4})))/SUMA(filter({F2;I2;L2;O2;R2;U2;X2;AA2;AD2;AG2;AJ2};ESNUMERO({G4;J4;M4;P4;S4;V4;Y4;AB4;AE4;AH4})))*5;2)*AL2/10;"-")

y la he cambiado una vez procesada por esta:

=SI.ERROR(REDONDEAR(SUMAPRODUCTO(filter({G4;J4;M4;P4;S4;V4;Y4;AB4;AE4;AH4};ESNUMERO({G4;J4;M4;P4;S4;V4;Y4;AB4;AE4;AH4}));filter({$F$2;$I$2;$L$2;$O$2;$R$2;$U$2;$X$2;$AA$2;$AD$2;$AG$2};ESNUMERO({G4;J4;M4;P4;S4;V4;Y4;AB4;AE4;AH4})))/SUMA(filter({$F$2;$I$2;$L$2;$O$2;$R$2;$U$2;$X$2;$AA$2;$AD$2;$AG$2};ESNUMERO({G4;J4;M4;P4;S4;V4;Y4;AB4;AE4;AH4})))*5;2)*$AL$2/10;"-")

Si te fijas, en el segundo filtro de la fórmula original aparece un AJ2 que ya no debe estar...simplemente lo he quitado las dos veces que sale en la fórmula. Como Corubrics escribe la fórmula siempre con referencias relativas he tenido que hacer bien la fórmula en la primera celda, y luego fijar con el símbolo $ filas y columnas para poder copiar (o arrastrar).

Temporalmente me he grabado una macro copiando las celdas de la columna ponderada, luego llamando a la función de reprocesar, y cuando ha acabado vuelvo a pegarlas (pero ya de nuevo con la fórmula bien). Por tanto uso la macro en vez de llamar a procesar respuestas de nuevo


 

Preguntas relacionadas

Estadística de Preguntas

48 visualizaciones
0 seguidores
Preguntado hace 7 meses
Vistas de este mes